PHP5.4でpukiwikiを動かすと画面が真っ白。

Google先生に聞いてみると、pukiwikiは開発が滞っており、PHP5.3やPHP5.4に対応していないためのようだ。

色々なサイトで独自に対応させている方がいるため、先人達に感謝しつつパッチ等を使わせていただく。

参考にしたサイト

ここに pukiwiki-1.4.7_notb_utf8.tar.gz にパッチを当てたpukiwikiを置いておく。

パッチのあて方

$ tar zxvf pukiwiki-1.4.7_notb_utf8-patch.tar.gz
$ rm pukiwiki-1.4.7_notb_utf8-patch.tar.gz
$ cd plugin
$ patch -p1 < ../pukiwiki_patch/attach.inc.php.patch
$ patch -p1 < ../pukiwiki_patch/ls2.inc.php.patch
$ cd ../lib
$ patch -p1 < ../pukiwiki_patch/config.php.patch
$ patch -p1 < ../pukiwiki_patch/convert_html.php.patch
$ patch -p1 < ../pukiwiki_patch/func.php.patch
$ patch -p1 < ../pukiwiki_patch/init.php.patch
$ patch -p1 < ../pukiwiki_patch/link.php.patch

いただいたパッチファイルも置いておく。

その他

Last-modified: 2014-01-28 (火) 10:39:48 (2143d)
トップ   編集 凍結 差分 バックアップ 添付 複製 名前変更 リロード   新規 一覧 単語検索 最終更新   ヘルプ   最終更新のRSS